Setting up Eclipse + PSPLink + GDBServer debugging

Discuss the development of new homebrew software, tools and libraries.

Moderators: cheriff, TyRaNiD

Post Reply
Def Base
Posts: 6
Joined: Mon Jul 17, 2006 9:24 am

Setting up Eclipse + PSPLink + GDBServer debugging

Post by Def Base »

Quick guide for anyone who wants to try out Eclipse. I use SuSE so cygwin/windows users will have to fiddle with the instructions. Bearing in mind I've hardly used Eclipse, I just played around until I got it all working, so use this as a guide and correct anything that's wrong.

1. Download Eclipse from I think that page detects your browser agent and puts the right download at the top of the list. I grabbed the linux one.

2. Untar it somewhere (I used /usr/local/bin/eclipse). It comes as a prebuilt exe so no compiling needed.

3. Run Eclipse as root, or at least with a user that has write permission to the Eclipse directory. The interface will be crappy but functional. Don't worry.

4. Go to Help -> Software Updates, select "Find new software to install".

5. Add a new Remote Site, name it "CDT" and set the URL to ... eclipse3.1. Uncheck any other update site options (I have Callisto and Eclipse), make sure only your new CDT entry is checked. CDT is the C/C++ extensions for Eclipse.

6. Make sure "Ignore features not applicable to the environment" is checked

7. Click Finish. Eclipse will go and check for new updates. It will find CDT, just check the entire tree (ie: click the top level checkbox). Hit Next, accept the license, let it run. It'll take a while if you're on a slow connect, lots to download. Did you forget to run Eclipse suid root? Bad luck, you're going to have to redownload everything :)

8. When it's finished it will prompt you to either restart the environment, quit Eclipse or carry on (not sure of the exact wording now, you'll see the prompt). Select "Restart Eclipse", or, if I've just suffered amnesia and there isn't an option, quit Eclipse then reload it as root. This is really really important because files are written during the reload.

9. When Eclipse has loaded, click the option to go to the workbench (far right icon/image thing). Go to Help - About, then click Plugin Details. If CDT installed you'll have lots of C/C++ items in the list.

10. Exit Eclipse again. Bored yet?

11. Open a shell and edit <install>eclipse/plugins/org.eclipse.cdt.debug.mi.core_3.0.2/plugins.xml

12. Look for tag: point="org.eclipse.cdt.debug.core.CDebugger", in this node you'll see cpu="native", change this to cpu="*". Save and exit.

13. Run Eclipse again as root but with the -clean flag specified as a command line option.

14. Finally quit Eclipse. Now you can start using it properly.

We'll debug the SDK sprite sample as a demo. This assumes you have PSPLink and PSP-GDB working from shell correctly.

15. Load Eclipse under your normal user account. Yay, it looks like a 21st Century IDE.

16. Go File - New Project. In the dialog expand "C" and select "Standard Make C". Hit Next, name the project "Sprite". Hit Finish.

17. You'll be left with an empty project (or workspace, or solution for you Visual Studio people). On the left hand side you'll see what would be a tree thing for your project, with Sprite at the top. Right click in the panel and select Import

18. Select General -> FileSystem and hit Next. The next dialog is basically an import browser for existing code. Use the top browse button to go and select the pspsdk/samples/gu/sprite directory. Don't worry, this process doesn't affect the original, it will create a duplicate in your workspace folder (which is your home folder by default). Make sure you select all the files, sometimes Eclipse didn't select everything.

19. Now we need to fiddle the SDK code. There are relative paths to headers in the common/ directory - because Eclipse duped the project into the workspace folder these are now broken. Fix the paths in sprite.c AND in Makefile.

Ok, that's what you have to do to get PSP code loaded into Eclipse. One thing that's *really* annoying if you're a VS user is Eclipse won't build changed files unless they're saved (Imight be wrong but it wouldn't for me). So go Window -> Preferences, expand General and click on Workspace. In there check "Save before build". Will save your sanity when you wonder why your new build didn't get the code changes :)

20. Now you can go Project -> Build Project or Build All. You might need to make a random change and save again before the build works. If you got it all right Eclipse will pick up the Makefile, use psp-gcc, pop the console window to front and show you the build output. You're done. Now you could switch back to pcterm and ./sprite.elf, but don't do that just yet.

21. Add the -g flag to CFLAGS in the Makefile to indicate we want debugging symbols (line 5:)

Code: Select all

CFLAGS = -g -G0 -Wall -O2
22. Go Project -> Clean and select Clean All. If you don't do this Eclipse won't pick up the addition of the -g flag in the makefile, and so won't rebuild the code. Anyone know how to get Eclipse to notice a change to the Makefile so we don't have to use the clean option?

23. Go Project -> Build Project. Check the output in the console to make sure the new -g flag in the Makefile was noticed.

Code: Select all

psp-gcc -I. -I/usr/local/pspdev/psp/sdk/include -g -G0 -Wall -O2   -c -o sprite.o sprite.c
24. Ok, we're done with the building. <deleted this step, was caused by some local issue to me>

25. Go to your pcterm session and type:

Code: Select all

debug ./sprite.elf
(obviously that assumes that usbhostfs_pc was started in the Eclipse workspace sprite directory - remember that Eclipse copies the source to the workspace, so if you selected /home/myarse as your workspace folder you'll need to start usbhostfs_pc /home/myarse/sprite)

26. A grand total of nothing should happen on your PSP, you'll see this in pcterm:

Code: Select all

host0&#58;/> debug ./sprite.elf

host0&#58;/> PSPLink GDBServer &#40;c&#41; 2k6 TyRaNiD/Lovely2
GDBServer&#58; Loaded host0&#58;/sprite.elf - UID 0x044C7627
27. Go back to Eclipse. Go to the Run menu and select Debug. You actually init the debug from this dialog, which isn't particularly obvious the first time you do it.

28. Click on "C/C++ Local Application", then click the New Item button (the paper sheet with the yellow star thing).

29. This will pop a new entry into the list and bring up its settings on the left side of the dialog. Name it something like PSPGDB or whatever. On the Main tab, select the sprite project for "Project" and select sprite.elf for the "C/C++ Application".

30. Skip all the other tabs, go to the Debugger tab. In the Debugger field, drop down the selection and choose GDB Server. Check "Stop at Main on startup". Under the "Main" subtab on the Debugger tab, enter psp-gdb for the debugger. Drop down the connection options and choose TCP, set Hostname to "localhost" (or if your box is retarded), set port to 10001.

31. Magically, if you got it all right, the Debug button at the bottom will spring into life. Click it!

32. Eclipse will look like it did nothing. Yes, this can be a dumb IDE IMO. But go to your usbhostfs session and (if you used -v option) you'll see all the GDB communications.

33. In Eclipse go to Window -> Open Perspective -> Debug. Yay, here's your debug stuff. As proof it works click the green arrow button that clearly looks like a Run option, and watch the PSP execute sprite.elf

Things I haven't quite figured out yet... Eclipse won't always show the values of vars. Also I can't get it to properly terminate the app on the PSP once you've clicked the run button (although you can terminate it properly if you've stopped at a breakpoint and are stepping over code). If anyone figures that out, let me know.

*edit* Tyranid says it's his fault, please fill his inbox with spam requesting it's fixed immediately ;)

Hopefully this will help someone, or at least provide a quick guide to trying out Eclipse. With a bit more work I'm pretty sure it can all be made mostly automatic.

It's Def. Really. Don't ask me why I used this username...

[DirectX Extraordinaire - that'll help me on the PSP]
Posts: 8
Joined: Thu Apr 20, 2006 10:49 am

Post by tyranos »

i need some help on this plz
i did everything as u said but im missing psp-gdb ,on psplink manual it says i should get a gdb version for psp arch but i dunno where to find one .

on the other hand i get the samples to compile and everything and can load them on the psp via pcterm only when i try to use the eclipse debugger i get this" Error creating session: Reply contains invalid hex digit 59
Reply contains invalid hex digit 59" and usbhostfs says gdb server connection accepted but it leaves right after that and i cant use the nice eclipse debugger ui

plz if someone knows the answer plz help
Posts: 35
Joined: Tue Jun 13, 2006 10:04 am

Post by DocMAX »

where can i get a precompiled psp-gdb? its not in my bin folder
User avatar
Posts: 22
Joined: Sun May 28, 2006 7:34 am

Post by lokust »

It's on svn. You can force the toolchain script to download & build it by supplying the -e -d flags.
Posts: 12
Joined: Wed Jun 01, 2005 7:58 pm

Post by lynx44 »

***CHECK FURTHER DOWN FOR A MUCH BETTER METHOD. This method works, but its basically a hack, a few posts down, I posted how to do it the "real" way.***

I got this compliling on windows with Cygwin, by following some of the directions above. I haven't actually gotten to the PSPLink part, just because I haven't installed it yet. I would suspect everything would work just how it does in Linux if you have everything installed, I just haven't checked yet.

This tutorial has a lot of explanation since I would like people to understand why this works. I know that we aren't here to necessarily teach people Windows or bash scripting, but I know that I didn't know much before I did this. I am not an expert, this is the first time I've ever done anything like this so I'm sure there are better ways to do this. However, to get it to use the make command from Cygwin, do the following:

1. Follow steps 1-15 above.

2. Go to File->New Project. In the dialog, select "Standard Make C". Name the project. Instead of copying over the contents of the project to your workspace, reference the actual files by unchecking the box named "Default" and pointing it to the "sprite" directory at your "/cygwin/usr/local/../gu/sprite" directory.

3. Right click on your project (in the left pane), and select "Properties." Click on the "Binary Parsers" tab and check the box next to "PE Windows Parser." This allows you to use Windows executables in order to compile your code. We'll be using cmd.exe to call cygwin, so this is a necessary step. Click "OK" and exit.

4. Create a batch file called "winmake" (you can call it whatever you want, this is what I called it) and put it into your Cygwin folder (for those that don't know what a batch file is, create a new text file, and name it winmake.bat, this is a script for windows). Right click on the file and click "Edit". Paste this code into the file:

Code: Select all

@echo off

C&#58;\cygwin\bin\bash -l -c C&#58;/cygwin/makescript
Make sure that you put the correct directory where Cygwin is installed, mine just happens to be installed in c:\cygwin.

Basically what this does is launches the bash shell (the command line system in cygwin) and executes a script, which we will be making in the next step. The -l flag means that the shell should behave as if we are actually using the command line system, otherwise it woudln't pay attention to our environment variables among other things (like the PATH variable that you set up when installing the toolchain). The -c flag indicates that we want to execute a command, in this case a script. "C:/cygwin/makescript" is calling the script, as if we had typed it into Cygwin.

5. Create the makescript script. This script is executed as a list of commands that you could theoretically type into cygwin. It always starts with "#!/bin/bash." Each line is a command. Put this code into the script:

Code: Select all

The first line is to identify that this is a bash script that should be executed. The second line changes the directory (in bash) to the directory of the makefile that you wish to compile. This variable will be set in Eclipse to the directory that you are working in (step 8). The third line calls the "make" command in your bin directory.

6. Tell Eclipse to use cmd.exe to call your batch file. Basically, your going to need to execute your batch file, and cmd.exe (the command prompt) is what handles that.

Switch to Eclipse, go to Run->Run... In the left pane, right click on C/C++ Local Application. Select "New." If you had your project selected in the workspace pane in the main window, this should automatically give it the name "Sprite." If not, click the "Browse" button, and select your project.

In C/C++ Application, enter the location of cmd.exe (mine was at c:\WINDOWS\system32\cmd.exe)

7. Give the command prompt the argument to run your project. In order to tell the command prompt to run your batch file, you have to pass in an argument. This is very similar to how we are passing the command to run our makescript for bash, in our batch file. The arguments for cmd.exe to run a command is "/c". In the "Run" dialog, switch to "Arguments" and put:

Code: Select all

/c C&#58;\cygwin\winmake
8. Ok, so we're pretty much done, but there's one more thing that needs to be defined before we can compile properly. Remember back in the makesript, we did a "cd $MAKEPATH"? That's the directory where the makefile is. This command tells bash to move to that directory first, before it calls make, just like you would do from the bash shell.

Click on the "Environment" tab in the "Run" dialog, then click on the "New" button. Name this variable, you guessed it, "MAKEPATH" and for the value, click "Variables." Select "${project_loc}" for the value, to reference the absolute path of this project. This will point you to usr/local/.../gu/sprite.

9. Click the "Apply" button, then click "Run". The console should display the same information that you would see when calling "make" within the Cygwin shell. If not there's something wrong, go back and recheck that you did everything correctly and are pointing to the right directories.

For every project you wish to compile, you'll have to setup the "Run" settings in this way in order to make it compile, but it should work for every makefile defined in the same way as the examples.

You could also use this method and define a new "Run" configuration called "Clean Sprite" if you wanted to clean out your folder each time. Again, there is probably a better way to do these things, but this is the way I figured it out, such as putting in all the information as one command line argument in eclipse instead of creating the batch file and the bash script. All suggestions are welcome.
Last edited by lynx44 on Thu Sep 14, 2006 1:13 pm, edited 1 time in total.
Posts: 13
Joined: Sat Sep 09, 2006 10:20 pm

Post by whazilla »


step 19 of first eclipse tut

19. Now we need to fiddle the SDK code. There are relative paths to headers in the common/ directory - because Eclipse duped the project into the workspace folder these are now broken. Fix the paths in sprite.c AND in Makefile.

don't seem to make sense to me ...
do i add upon my source and edit the paths in th #include <somefile>

or do i add included dirs ? ... allso my eclipse don't seem to find /lib/build.mak :$

while in bash all works

hope to reconfigured
Posts: 12
Joined: Wed Jun 01, 2005 7:58 pm

Post by lynx44 »

He just means reference the full path of the files. Since they were relocated, they used to be one directory back in the common folder, but now your the project has been copied to your workspace folder, so there is no common folder one directory below.

If you instead create your Sprite project by creating a Standard Make C project, then uncheck "Use Default" and point it to your Sprite folder (in usr/local/.../pspsdk/samples/gu/sprite), you won't need to worry about this.

Posts: 12
Joined: Wed Jun 01, 2005 7:58 pm

Post by lynx44 »

Ok, here's the real way to set up Eclipse in Windows. First, make sure you have PSPSDK all set up in Cygwin.

1. Install CDT into Eclipse just as said in the above tutorial.

2. Import the Sprite project, as in the above Windows tutorial (Step 2).

3. Right click on your project, then click "Properties." Click on "C/C++ Make Project" in the left pane.

4. Click on the "Environment" tab. Add your PATH variable. Set this to "C:\cygwin\bin;/usr/local/pspdev/bin;$PATH" (or wherever you installed your cygwin bin and pspdev bin directories)

Add your PSPSDK variable, set this value to "C:/cygwin/usr/local/pspdev/psp/sdk" (or wherever you SDK resides)

5. Click on the "Binary Parsers" tab, check only the "Cygwin PE Parser" box. Make sure all other boxes are unchecked.

6. Click "Apply" at the bottom, and in your console you should see your project building. If not, I either forgot to tell you something in this tutorial, or you missed a step. Go back and recheck everything, then post your error message here.

Posts: 13
Joined: Sat Sep 09, 2006 10:20 pm

Post by whazilla »

hi matt,

i still got an issue tho
i tried all in this thread (above)

make -k all
make: psp-config: Command not found
Makefile:17: \lib\build.mak: No such file or directory
make: *** No rule to make target `\lib\build.mak'.
make: Failed to remake makefile `\lib\build.mak'.
make: *** No rule to make target `all'.
User avatar
Posts: 123
Joined: Wed Oct 05, 2005 6:15 am

Post by harleyg »

Set $PATH whazilla...
Thats the only reason why it's saying that.
Posts: 13
Joined: Sat Sep 09, 2006 10:20 pm

Post by whazilla »


finally got it workin seemed it was the dollar sign

i setted PATH while it had tobe $PATH
same for PSPSDK

thkx y'all :D
Posts: 29
Joined: Sat Oct 14, 2006 11:59 pm

Post by goebish »

Hi, everything works fine except psp-debug:

Code: Select all

&#40;gdb&#41; target remote &#58;10001
Remote debugging using &#58;10001
Ignoring packet error, continuing...
Ignoring packet error, continuing...
Ignoring packet error, continuing...
Malformed response to offset query, timeout
I searched the forum for some help but I can't solve my problem.

- I compiled the toolchain, psplink (2.0 final), usbhostfs_pc and psp-gdb from the latest svn.
- I can launch .elf files from the usb shell
- I compiled with the -g flag
- I can run debug ./sprite.elf:

Code: Select all

host0&#58;/>  debug ./sprite.elf
host0&#58;/>  PSPLink GDBServer &#40;c&#41; 2k6 TyRaNiD/Lovely2
GDBServer&#58; Loaded host0&#58;/sprite.elf - UID 0x017D791F
- usbhost & usbgdb are enable in psplink.ini

I use linux (debian current stable), maybe I miss something about the driver (.inf) needed in windows for usbhost. Do I need something similar under linux ?

Thank for your help :)

Edit: oops, I replied the wrong thread.
Can A mod delete this reply please ?
Posts: 70
Joined: Tue Jun 07, 2005 9:18 pm

gdb build not working...

Post by HexDump »

I have tryied to download an compile gdb ( I used the toolcahin script with the -d and -e switches as someone states above).

I get this error:

hecking target system type... Invalid configuration `psp': machine `psp' not recognized
configure: error: /bin/sh ../../bfd/../config.sub psp failed

could anybody help here please?.

Thanks in advance,
Posts: 2
Joined: Tue Oct 17, 2006 8:02 am

Post by Soily »

Hi HexDump,
I had the same problem as you earlier today when running the script with the flags mentioned above, and I fixed it by running "svn update" in the toolchain directory before running the script. I hope it will work for you.

I also have a problem now, I can't run the debugger from inside Eclipse. [NB : I'm using Windows.] I followed all the steps described in this tutorial (with more or less trouble :P ), and I reached step #32 where you click the "Debug" button, but it didn't work for me. I have an error message when I try to debug :
"Error creating session"
And the details are:
Exec error : Launching failed
(message displayed 3 times)

I have everything else running (PSPLink, USBHostFS and the GDBServer)

Does anyone know what the problem can be? Any help would be greatly appreciated!


[EDIT] I managed to solve my problem. I only needed to add the $PSPSDK/bin directory to my windows PATH (or to give the full path to the psp-gdb executable in the Debugger dialog). It works now ! [/EDIT]
Posts: 70
Joined: Tue Jun 07, 2005 9:18 pm

Post by HexDump »

Thanks a lo soily but this neither works :(. When I run svn update I get a message saying: Omiting '.' (this could be not the real message in a linux with english language, I translated from spanish) then, it exists.

WHere do you execute it? where the is? does it do anything more than printint the "Ominit '.' " message?.

Sorry mate can help you with your problem :(.

Posts: 4
Joined: Sat Jan 20, 2007 9:58 pm

Doing it all out of eclipse

Post by stelzbock »

Hi, I followed lynx44 steps and got all working, really cool. Next I tried to start the compiled .elf via run without any cygwin console. First Step was to start usbhostfs_pc.exe as external tool in eclipse
1.) Go to Run --> External Tools --> External Tools
2.) Right click on Program, give it a name
2.) In "Main" tab select the location of your usbhostfs_pc.exe
3.) Select the working directory for your eclipse projects
4.) In "Environment" tab. Set your PATH variable like in lynx44 Step 4
5.) Check in "Common" tab "Display in favorite menu" "External Tools"
Now you can start usbhostfs_pc.exe as external tool from eclipse.

Next step was to start the application via "Run As"
1.) Right click on your project (Hello World) --> Run As --> Run ...
2.) Right click on C/C++ Application --> New, give it a name
3.) In main tab C/C++ Application Field choose the path to your pcterm.exe
(e.g. c:\cygwin\home\Administrator\psplink\pcterm\pcterm.exe)
4.) In "Environment" tab. Set your PATH variable like in lynx44 Step 4
5.) In "Arguments" tab -c ./${project_path}/${project_name}.elf
Only works if your .elf file has the same name like your project.
I had to patch pcterm.exe to execute a given command with "-c" option.
Now you can start your application with Run.

Here is my patch for pcterm.c

Index: pcterm.c
--- pcterm.c (Revision 2130)
+++ pcterm.c (Arbeitskopie)
@@ -45,6 +45,7 @@
const char *ip;
const char *hist;
const char *log;
+ const char *command;
unsigned short port;
unsigned int baud;
unsigned int realbaud;
@@ -282,9 +283,9 @@
int error = 0;

- ch = getopt(argc, argv, "sp:h:r:b:l:");
+ ch = getopt(argc, argv, "sp:h:r:b:l:c:");
- ch = getopt(argc, argv, "p:h:r:");
+ ch = getopt(argc, argv, "p:h:r:c:");
if(ch < 0)
@@ -301,6 +302,9 @@
case 'l': args->log = optarg;
+ case 'c': args->command = optarg;
+ break;
case 'b': args->baud = map_int_to_speed(atoi(optarg));
args->realbaud = atoi(optarg);
@@ -353,6 +357,7 @@
fprintf(stderr, "-h history : Specify the history file (default ~/%s)\n", HISTORY_FILE);
fprintf(stderr, "-r retries : Number of connection retries (default %d)\n", CONNECT_RETRIES);
fprintf(stderr, "-l logfile : Write out all shell text to a log file\n");
+ fprintf(stderr, "-c command : Specify a command to execute\n");
fprintf(stderr, "-b baud : Specify the baud rate (default %d)\n", BAUD_RATE);
fprintf(stderr, "-s : Set serial mode\n");
@@ -597,7 +602,7 @@
return 1;

-void shell(void)
+void shell(const char* command)
fd_set readset, writeset;

@@ -660,6 +665,14 @@

if(g_context.state == STATE_CONNECTED)
+ if(command)
+ {
+ fprintf(stderr, "executing command %s\n", command);
+ execute_line(command);
+ command = 0L;
+ g_context.exit = 1;
+ }
if(FD_ISSET(g_context.sock, &readset))
/* Do read */
@@ -744,7 +757,7 @@
- shell();
+ shell(g_context.args.command);
if(g_context.sock >= 0)
Posts: 24
Joined: Tue Aug 29, 2006 11:54 pm

Post by onne »

finally I got the Debugging to work on Windows + Eclipse + Cygwin... Works like a dream. :) I just wanted to let you know if someone else is having the following problem:
When you first start debug your application on pcterm, and then start the debug on eclipse, you get error "Source not found"

The solution is:
1. go to the Debug View and right click the top node in the tree, select "Edit source lookup"
2. Add... , "Path Mapping"
3. Select the "Path Mapping" you created and click Edit, and Add..
4. Enter your project directory in unix style to the Compilation path, ie.
and Local file system path, ie.
5. Ok, and you are done!
Last edited by onne on Fri Mar 02, 2007 11:29 am, edited 1 time in total.
User avatar
Posts: 38
Joined: Tue Jan 24, 2006 2:21 pm

Post by Barts_706 »

Interesting. I might try it.
Posts: 13
Joined: Wed Nov 22, 2006 12:28 am

Post by tabularasa »

Everything works fine until i close eclipse and start it again, after i imported the project:

!SESSION 2007-06-30 23:09:04.350
java.fullversion=GNU libgcj 4.1.2 (Ubuntu 4.1.2-0ubuntu5)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_EN
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 2 1 2007-06-30 23:09:05.640
!MESSAGE NLS missing message: initializer_error in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-06-30 23:09:05.640
!MESSAGE NLS missing message: fileInitializer_fileNotFound in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-06-30 23:09:05.640
!MESSAGE NLS missing message: fileInitializer_IOError in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-06-30 23:09:05.641
!MESSAGE NLS missing message: fileInitializer_missingFileName in: org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.ui.workbench 4 2 2007-06-30 23:09:17.735
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
at org.eclipse.cdt.internal.ui.text.CTextTools.adaptToPreferenceChange(
at org.eclipse.cdt.internal.ui.text.CTextTools$PreferenceListener.propertyChange(
at org.eclipse.ui.preferences.ScopedPreferenceStore$
at org.eclipse.ui.preferences.ScopedPreferenceStore.firePropertyChangeEvent(
at org.eclipse.ui.preferences.ScopedPreferenceStore.setToDefault(
at org.eclipse.ui.texteditor.MarkerAnnotationPreferences.useAnnotationsPreferencePage(
at org.eclipse.ui.editors.text.EditorsUI.useAnnotationsPreferencePage(
at org.eclipse.cdt.ui.CUIPreferenceInitializer.initializeDefaultPreferences(
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.runInitializer(PreferenceServiceRegistryHelper.jav
at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.applyRuntimeDefaults(PreferenceServiceRegistryHelp
at org.eclipse.core.internal.preferences.PreferencesService.applyRuntimeDefaults(
at org.eclipse.core.internal.preferences.DefaultPreferences.applyRuntimeDefaults(
at org.eclipse.core.internal.preferences.DefaultPreferences.loadDefaults(
at org.eclipse.core.internal.preferences.DefaultPreferences.load(
at org.eclipse.core.internal.preferences.EclipsePreferences.create(
at org.eclipse.core.internal.preferences.EclipsePreferences.internalNode(
at org.eclipse.core.internal.preferences.EclipsePreferences.node(
at org.eclipse.core.internal.preferences.AbstractScope.getNode(
at org.eclipse.core.runtime.preferences.DefaultScope.getNode(
at org.eclipse.ui.preferences.ScopedPreferenceStore.getDefaultPreferences(
at org.eclipse.ui.preferences.ScopedPreferenceStore.getPreferenceNodes(
at org.eclipse.ui.preferences.ScopedPreferenceStore.internalGet(
at org.eclipse.ui.preferences.ScopedPreferenceStore.getString(
at org.eclipse.jface.preference.PreferenceConverter.getColor(
at org.eclipse.cdt.internal.ui.text.AbstractCScanner.addToken(
at org.eclipse.cdt.internal.ui.text.AbstractCScanner.initialize(
at org.eclipse.cdt.internal.ui.text.CCodeScanner.<init>(
at org.eclipse.cdt.internal.ui.text.CTextTools.<init>(
at org.eclipse.cdt.ui.CUIPlugin.getTextTools(
at org.eclipse.cdt.internal.ui.editor.CEditor.initializeEditor(
at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.<init>(
at org.eclipse.ui.editors.text.TextEditor.<init>(
at org.eclipse.cdt.internal.ui.editor.CEditor.<init>(
at java.lang.Class.newInstance(
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(
at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(
at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(
at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(
at org.eclipse.ui.internal.registry.EditorDescriptor.createEditor(
at org.eclipse.ui.internal.EditorManager.createPart(
at org.eclipse.ui.internal.EditorReference.createPartHelper(
at org.eclipse.ui.internal.EditorReference.createPart(
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(
at org.eclipse.ui.internal.EditorReference.getEditor(
at org.eclipse.ui.internal.WorkbenchPage.makeActiveEditor(
at org.eclipse.ui.internal.WorkbenchPage.updateActivePart(
at org.eclipse.ui.internal.WorkbenchPage.handleDeferredEvents(
at org.eclipse.ui.internal.WorkbenchPage.deferUpdates(
at org.eclipse.ui.internal.WorkbenchPage.restoreState(
at org.eclipse.ui.internal.WorkbenchWindow.restoreState(
at org.eclipse.ui.internal.Workbench.doRestoreState(
at org.eclipse.ui.internal.Workbench.access$14(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.ui.internal.Workbench.runStartupWithProgress(
at org.eclipse.ui.internal.Workbench.restoreState(
at org.eclipse.ui.internal.Workbench.access$12(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.ui.internal.Workbench.restoreState(
at org.eclipse.ui.internal.WorkbenchConfigurer.restoreState(
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(
at org.eclipse.ui.internal.Workbench.init(
at org.eclipse.ui.internal.Workbench.runUI(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.eclipse.core.internal.runtime.PlatformActivator$
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at java.lang.reflect.Method.invoke(
at org.eclipse.core.launcher.Main.invokeFramework(
at org.eclipse.core.launcher.Main.basicRun(
at org.eclipse.core.launcher.Main.main(
Posts: 328
Joined: Sun Jun 03, 2007 10:05 pm

Post by KickinAezz »

Any tutorials on how to set it up with Code::Blocks or any such ide?
Posts: 1
Joined: Fri Jul 18, 2008 12:56 am

Post by drColossus »

Dunno if anyone checks this anymore. But its worth a shot.

Im quite close to getting Eclipse working as my debugger. However when I go to debug any PSP apps, eclipse shows this error message.

'Launching PSPGDB' has encountered a problem
Error Creating Session

Lower down it say (3 times):

Process Terminated

Any help with this would be great as Im so close to getting this working.

Post Reply