Big problems with spu-medialib...

"A collection of spu programs to accelerate media related applications for the CellBE ( PS3 ) platform" - unsolo

Moderator: unsolo

Post Reply
Dannydeman
Posts: 2
Joined: Thu Mar 27, 2008 9:27 pm

Big problems with spu-medialib...

Post by Dannydeman »

I have firmware 2.20 and Xubuntu with all codecs. Movies do play fine in VLC if I don't use this spu-medis stuff. I followed to different guides to have better quality and playback thoug.

The first:

http://linux.yes.nu/PS3Ubuntu/?Page=c3VtbWFyeTAz

This was the most easy one, but when I try this Mplayer goes black, I hear sound for 1 second and the system won't respond (only through SSH)

The second one I tried:

http://psubuntu.com/forums/viewtopic.php?f=4&t=38

This one was a little more advanced, but since this works for all players (also VLC) this was the best for me... I followed the guide step by step and the install went great...but guess what? If I start a movie in VLC, it loads for one second (i hear sound) then it auto-shutdown VLC...

In the terminal I see this error:

VLC media player 0.8.6c Janus
X Error of failed request: 255
Major opcode of failed request: 140 (XVideo)
Minor opcode of failed request: 19 ()
Serial number of failed request: 83
Current serial number in output stream: 84

I realy like some help or suggestions, since I bought my PS3 to build a Linux Freevo Mediacenter..
unsolo
Posts: 155
Joined: Mon Apr 16, 2007 2:39 am
Location: OSLO Norway

Post by unsolo »

Spu medialib has still not gotten a release (sorry i should release a version i know it)

The only help i give is to people who compile spu-medialib libps3fb and mplayer from source then have an issue including a detail printout of the problem.

I personally buildt spu-medialib + libps3fb and mplayer on my 32 bit ps3 about 3 weeks ago and i had no problem playing back quitting and resuming.

I did have to do a small patch job to get it working but in general that was all.

I have firmware over 2.20 on both my 32 bit userland and my 64 bit userland ps3's without having these issues however i am using gentoo linux.

Do not dispair im pretty sure you can get it working try reading various posts on this forum..
Don't do it alone.
zzima
Posts: 10
Joined: Thu Mar 13, 2008 11:57 pm

Post by zzima »

unsolo wrote: I have firmware over 2.20 on both my 32 bit userland and my 64 bit userland ps3's without having these issues however i am using gentoo linux.

Do not dispair im pretty sure you can get it working try reading various posts on this forum..
If you will pay a bit more attention to this forum, then you'll notice that spu-medialib + libps3fb + mplayer have problems working on 6.0 YDL.
It's compiling fine, but simply does not work (as I stated before - green garbage for all file types).
Chinaphoro
Posts: 47
Joined: Mon Jan 03, 2022 10:15 am
Location: http://product-of-china.cf/
Contact:

-

Post by Chinaphoro »

i dont think its an add-on cuz i tried it without any add-ons, only with the roster and it doesnt work i changed the BADD to 1 when i did that
Post Reply